YetAnotherForum
Welcome Guest Search | Active Topics | Log In

Nuno and AIS Options
hornloaded
#1 Posted : Saturday, May 12, 2012 11:02:12 AM
Rank: Member

Groups: Registered

Joined: 4/27/2012
Posts: 8
I am currently running the software on a 12V windows 7 machine. I have a USB GPS receiver connected. I run Air display to put the system on my I pad for use at the helm. All of this works great!
I now want to add AIS information.
I have found this AIS receiver:
http://www.milltechmarin...AIS-Receiver_p_234.html

My question is, will the program use both the GPS (my location) and the AIS (everybody else location) at the same time?

Thanks
Doug
Moonshadow
Chris
#2 Posted : Monday, May 14, 2012 5:24:20 AM
Rank: Administration

Groups: Moderators, Administrators, Registered

Joined: 7/23/2010
Posts: 29
Hi Doug
This should work fine. Nuno scans all available COM and USB ports for recognisable NMEA data strams and will interprete each stream it can understand.

AIS target symbols will be displayed for each identified target, together with velocity vectors where they are advertising being under way. You can see an overview of the AIS functionality in Nuno in Simon's blog post on AIS.

Regards

Chris
Nuno Navigator Support
Chris Johnson
Nuno Navigator Support
hornloaded
#3 Posted : Sunday, May 20, 2012 4:40:35 PM
Rank: Member

Groups: Registered

Joined: 4/27/2012
Posts: 8
Chris,
I installed my AIS receiver today. Im not seeing it on Nuno Navigator.
I am coming in on Com 4. I have a little program that reads NMEA data and confirmed it is sending data. I found another little program and can now read the ship messages being received, so I know the receiver and connection to the computer is all working.
My GPS location is working, and I tried disconnecting the GPS from the system with no luck.

Any ideas?

Thanks
Doug
Chris
#4 Posted : Monday, May 21, 2012 1:18:32 PM
Rank: Administration

Groups: Moderators, Administrators, Registered

Joined: 7/23/2010
Posts: 29
Hi Doug
Did you make sure that nothing else had attached to the COM port before starting Nuno? If another application locks the port (your monitor program?) Nuno will not attach to it.

You can turn logging on by changing a registry setting. The usual warnings apply - be careful and save before making a change.

Go to
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\CherSoft\Nuno Navigator\Communications

change the 'Log Folder' entry to include the full path to a writable folder (e.g. c:\temp\)

Restart nuno.

After running Nuno for a while, see if anything is in the folder. It will record any data it sees in a file SerialPortDataLog_COMx.txt (where x=4 in your case)

You could also capture the data you see with your monitor application.

If you send the captured data to us we can have a look at what might be happening.

Another diagnostic task would be to disconnect the GPS, connect the AIS, start Nuno. Open the Route Monitor window (show, Route Monitor). Hover over the COM port status box and let me know what it reports.

Regards
Chris
Chris Johnson
Nuno Navigator Support
hornloaded
#5 Posted : Monday, May 21, 2012 1:29:40 PM
Rank: Member

Groups: Registered

Joined: 4/27/2012
Posts: 8
I did confirm the port was available. And Nuno was locking the port when it was running. The only way I could use the other programs was to shut Nuno down. I will try the other suggestions this afternoon when I head out to the boat and report back.

Thanks
Doug
Chris
#6 Posted : Friday, June 22, 2012 10:03:09 AM
Rank: Administration

Groups: Moderators, Administrators, Registered

Joined: 7/23/2010
Posts: 29
Hi Doug
Did you manage to get your AIS input hooked up to Nuno?

Regards
Chris

Nuno Navigator Support
Chris Johnson
Nuno Navigator Support
Users browsing this topic
Guest (5)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAFVision Theme by Jaben Cargman (Tiny Gecko)
Powered by YAF 1.9.301 | YAF © 2003-2009, Yet Another Forum.NET
This page was generated in 0.143 seconds.